YD/T 21432010 基于国际多语种域名体系的中文域名的编码处理技术要求.pdf

YD/T 2143-2010 基于国际多语种域名体系的中文域名的编码处理技术要求.pdf文档页数:64文档大小:18.49MB文档格式:pdf ICS33.040.40 M32 YD 中华人民共和国通信行业标准 YD/T2143-2010 基于国际多语种域名体系的 中文域名编码处理技术要求 Technical specification for codi...

YD/T 2143-2010 基于国际多语种域名体系的中文域名的编码处理技术要求.pdf

文档页数:64文档大小:18.49MB文档格式:pdf

ICS33.040.40 M32 YD 中华人民共和国通信行业标准 YD/T2143-2010 基于国际多语种域名体系的 中文域名编码处理技术要求 Technical specification for coding of Chinese domain names 2010-12-29发布 2011-01-01实施 中华人民共和国工业和信息化部发布 YD/T2143-2010 目 次 前言 Ⅱ 引言 I 1范围 1 2规范性引用文件 1 3术语、定义和缩略语1 3.1术语和定义1 3.2缩略语 3 4字符串预处理和中文域名字段预处理 3 4.1字符串预处理框架 .3 4.2字符预备处理概要 4 4.3映射 4.4归一化 5 4.5禁止输出6 4.6双向字符 4 7字符串预处理框架中的未分配码位6 4.8中文域名字段预处理 7 5 Punycode编码 7 5.1 Punycode特点 7 5.2 Bootstring架构 8 5.3 Bootstring参数 9 5.4 Punycode参数值- 10 5.5 Bootstring算法10 5.6 Punycode算法实现例子13 附录A(规范性附录)UNICODE保留字符表14 附录B(规范性附录)映射表 17 附录C(规范性附录)禁止输出表38 附录D(规范性附录)双向字符表 41 附录E(资料性附录)punycode编码解码例子 44 附录F(资料性附录)punycode算法编码解码C语言实现例子46 I YD/T2143-2010 前言 本标准在技术内容上与ETF RFC3454《国际化字符串预处理》(2002年英文版)、ETF RFC3491 《国际化域名预处理》(2003年英文版)和ETF RFC3492《一种适用于国际化域名应用的对UNICODE 码的编码方法:punycode》(2003年英文版)保持一致,实现本标准与实现ETF RFC3454、IETF RFC3491 和ETF RFC3492的结果是一样的. 本标准是中文域名标准系列之一,该系列标准的名称和结构如下: 1)基于国际多语种域名体系的中文域名总体技术要求 2)基于国际多语种域名体系的中文域名的编码处理规范 3)基于国际多语种域名体系的中文域名的一系列应用协议规范和协议测试规范 4)基于国际多语种域名体系的中文域名的一系列软件设计规范和软件测试规范 5)基于国际多语种域名体系的中文域名注册实施规范 本标准的附录A、附...

本文来自叛逆风云投稿,不代表文丁图集立场,如若转载,请注明出处:https://www.2b34.com/blog/139369.html

打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
() 0
上一篇 11-18
下一篇 11-18

相关推荐

  • SJ/T 117242018 锂原电池用电解液.pdf

    SJ/T 11724-2018 锂原电池用电解液.pdf文档页数:8文档大小:471.55KB文档格式:pdf ICS31.030 L90 备案号: SJ 中华人民共和国电子行业标准 SJ/T11724—2018 锂原电池用电解液 Electrolyte solution used for lithium primary battery 2018-04-30发布 2018-07-01实施 中华人

    2026-10-02 14:16:01
    201 0
  • JB/T 201892017 生物废水灭活装置

    JB/T 20189-2017 生物废水灭活装置附件大小:2.44MB附件格式:1个直链文件,格式为pdf 资源简介:ICs11.120.30C92备案号:60769一2018中华人民共和国制药机械行业标准JB/T20189-2017生物废水灭活装置Biological waste water inactivate equipment2017-11-07发布2018-04-01实施

    2026-10-02 13:08:02
    125 0
  • QB/T 54332019 工业用缝纫机 钉扣机机针.pdf

    QB/T 5433-2019 工业用缝纫机 钉扣机机针.pdf文档页数:10文档大小:1.21MB文档格式:pdf ICS61.080 分类号:Y17 QB 中华人民共和国轻工行业标准 QB/T5433-2019 工业用缝纫机钉扣机机针 Industrial sewing machine -Sewing needle of the button attaching sewing machine 20

    2026-10-02 12:08:01
    862 0
  • QJ 204152016 运载火箭总体网系统综合试验方法.pdf

    QJ 20415-2016 运载火箭总体网系统综合试验方法.pdf文档页数:12文档大小:2.82MB文档格式:pdf QJ 中华人民共和国航天行业标准 FL1680 QJ20415-2016 运载火箭总体网系统综合试验方法 Integrated test method for collectivity network system of launch vehicle 2016一01一1

    2026-10-02 12:00:01
    748 0

评论列表

联系我们

在线咨询: QQ交谈

邮件:admin@qq.com

工作时间:周一至周五,9:30-18:30,节假日休息

关注微信